Chung cư OCT1-ĐN2-X1, Bắc Linh Đàm, Hoàng Mai, Hà Nội

Mạng VLAN là gì? Hướng dẫn cấu hình VLAN

                                        Cấu hình VLAN Swith Cisco

VLAN là viết tắt của Virtual Local Area Network hay còn gọi là mạng LAN ảo. Một VLAN được định nghĩa là một nhóm logic các thiết bị mạng và được thiết lập dựa trên các yếu tố như chức năng, bộ phận, ứng dụng… của công ty

VLAN là viết tắt của Virtual Local Area Network hay còn gọi là mạng LAN ảo. Một VLAN được định nghĩa là một nhóm logic các thiết bị mạng và được thiết lập dựa trên các yếu tố như chức năng, bộ phận, ứng dụng… của công ty

 Hiện nay, VLAN đóng một vai trò rất quan trọng trong công nghệ mạng LAN. Để thấy rõ được lợi ích của VLAN, chúng ta hãy xét trường hợp sau :

Giả sử một công ty có 3 bộ phận là: Engineering, Marketing, Accounting, mỗi bộ phận trên lại trải ra trên 3 tầng. Để kết nối các máy tính trong một bộ phận với nhau thì ta có thể lắp cho mỗi tầng một switch. Điều đó có nghĩa là mỗi tầng phải dùng 3 switch cho 3 bộ phận, nên để kết nối 3 tầng trong công ty cần phải dùng tới 9 switch. Rõ ràng cách làm trên là rất tốn kém mà lại không thể tận dụng được hết số cổng (port) vốn có của một switch. Chính vì lẽ đó, giải pháp VLAN ra đời nhằm giải quyết vấn đề trên một cách đơn giản mà vẫn tiết kiệm được tài nguyên.

Như hình vẽ trên ta thấy mỗi tầng của công ty chỉ cần dùng một switch, và switch này được chia VLAN. Các máy tính ở bộ phận kỹ sư Engineering) thì sẽ được gán vào VLAN Engineering, các PC ở các bộ phận khác cũng được gán vào các VLAN tương ứng là Marketing và kế toán (Accounting). Cách làm trên giúp ta có thể tiết kiệm tối đa số switch phải sử dụng đồng thời tận dụng được hết số cổng (port) sẵn có của switch.

Phân loại VLAN

  • Port – based VLAN: là cách cấu hình VLAN đơn giản và phổ biến. Mỗi cổng của Switch được gắn với một VLAN xác định (mặc định là VLAN 1), do vậy bất cứ thiết bị host nào gắn vào cổng đó đều thuộc một VLAN nào đó.
  • MAC address based VLAN: Cách cấu hình này ít được sử dụng do có nhiều bất tiện trong việc quản lý. Mỗi địa chỉ MAC được đánh dấu với một VLAN xác định.
  • Protocol – based VLAN: Cách cấu hình này gần giống như MAC Address based, nhưng sử dụng một địa chỉ logic hay địa chỉ IP thay thế cho địa chỉ MAC. Cách cấu hình không còn thông dụng nhờ sử dụng giao thức DHCP.

Lợi ích của VLAN

  • Tiết kiệm băng thông của hệ thống mạng:
    VLAN chia mạng LAN thành nhiều đoạn (segment) nhỏ, mỗi đoạn đó là một vùng quảng bá (broadcast domain). Khi có gói tin quảng bá (broadcast), nó sẽ được truyền duy nhất trong VLAN tương ứng. Do đó việc chia VLAN giúp tiết kiệm băng thông của hệ thống mạng.
  • Tăng khả năng bảo mật:
    Do các thiết bị ở các VLAN khác nhau không thể truy nhập vào nhau (trừ khi ta sử dụng router nối giữa các VLAN). Như trong ví dụ trên, các máy tính trong VLAN kế toán (Accounting) chỉ có thể liên lạc được với nhau. Máy ở VLAN kế toán không thể kết nối được với máy tính ở VLAN kỹ sư (Engineering).
  • Dễ dàng thêm hay bớt máy tính vào VLAN:
    Việc thêm một máy tính vào VLAN rất đơn giản, chỉ cần cấu hình cổng cho máy đó vào VLAN mong muốn.
  • Giúp mạng có tính linh động cao:
    VLAN có thể dễ dàng di chuyển các thiết bị. Giả sử trong ví dụ trên, sau một thời gian sử dụng công ty quyết định để mỗi bộ phận ở một tầng riêng biệt. Với VLAN, ta chỉ cần cấu hình lại các cổng switch rồi đặt chúng vào các VLAN theo yêu cầu.
    VLAN có thể được cấu hình tĩnh hay động. Trong cấu hình tĩnh, người quản trị mạng phải cấu hình cho từng cổng của mỗi switch. Sau đó, gán cho nó vào một VLAN nào đó. Trong cấu hình động mỗi cổng của switch có thể tự cấu hình VLAN cho mình dựa vào địa chỉ MAC của thiết bị được kết nối vào.
VLAN: là kỹ thuật chuyển mạch lớp 2 và định tuyến của lớp 3 để giới hạn miền đụng độ và miền quảng bá.
  • VLAN giúp Phân nhóm user theo từng phòng ban (mỗi VLAN là một subnet riêng biệt).

Ví dụ: 1 switch có 24 port ta chia

    • port 1-8 là phòng sale
    • port 9-16 là phòng kinh doanh
    • port 17-24 là phòng kỹ thuật
  • VLAN đáp ứng chất lượng dịch vụ QoS: Khi trong hệ thống mạng có nhiều traffic như: Voice, management, data mà ta cần ưu tiên traffic voice đi trước sau đó tới management, data … thì ta phải gán từng traffic cho từng VLAN (vì switch sử dụng công nghệ share bandwith) và set độ ưu tiên cho từng VLAN

VLAN được chia làm 2 loại chính:

  • Static VLAN:
    • VLAN tĩnh là cách phổ biến nhất để tạo VLAN, và cũng là cách bảo mật nhất.
    • Các port của VLAN luôn luôn được duy trì đến khi người quản trị thay đổi.
  • Dynamic VLAN:
    • Thiết lập VLAN dựa trên MAC address, protocol, application.
    • MAC address của máy nào đó đã được nhập vào 1 ứng dụng quản lý tập trung VLAN.
    • Nếu 1 node mạng được gắn vào 1 cổng không được chỉ định trên switch, VLAN có thể dò tìm địa chỉ phần cứng và ấn định cấu hình các cổng chuyển đổi vào đúng VLAN.

Lợi ích của VLAN:

  • Bảo mật.
  • Giảm chi phí.
  • Hiệu suất cao.
  • Giảm thiểu tình trạng “Broadcast storm”.
  • Nâng cao hiệu suất làm việc của IT.

Cấu hình VLAN Swith Cisco

  1. Tạo VLAN bằng lệnh:
  • n thuộc 0 – 4095
  • VLAN 0 và 4095: không được sử dụng.
  • VLAN 1 : VLAN default
  • VLAN 2 – 1001: Normal range (có thể sử dụng được)
  • VLAN 1002 đến 1005: VLAN default, dùng để kết nối với các hệ thống mạng khác như: FDDI, token Ring …(không kết nối được system Ethernet)
  • VLAN 1006 – 4094: VLAN extended range (dùng cho các Switch Transparent)

2. Đặt tên cho VLAN (các VLAN default thì không đặt tên được)

3. Gán port vào VLAN

  • Chọn Interface
  • Chuyển SW về mode access (mode access dùng để kết nối các end user)
  • Gán các port vào VLAN của mình

4. Gán 1 range port vào VLAN

Thiết lập mô hình mạng như mô hình logic Cấu hình VLAN Swith Cisco

Thực hiện các yêu cầu sau

  • Cấu hình cơ bản trên các switch
  • Tạo các VLAN
  • Gán các port đến một VLAN
  • Thêm, xoá và thay đổi các port
  • Kiểm tra cấu hình VLAN
  • Kích hoạt trunking trên các kết nối liên switch
  • Kiểm tra cấu hình trunk
  • Sao lưu cấu hình trunk

Hướng dẫn thực hiện “step by step”

Bảng địa chỉ IP
Khởi tạo, gán các portCấu hình cơ bản trên các switch

Xem thêm Cấu hình cơ bản trên Switch, Router Cisco

  • Cấu hình host name
  • Cấu hình mật khẩu chế độ EXEC: class
  • Cấu hình mật khẩu kết nối console: cisco
  • Cấu hình mật khẩu kết nối vty: cisco

Tạo các VLANs trên switch S1:

  • S1(config)#vlan 10
  • S1(config-vlan)#name faculty/staff
  • S1(config-vlan)#vlan 20
  • S1(config-vlan)#name students
  • S1(config-vlan)#vlan 30
  • S1(config-vlan)#name guest
  • S1(config-vlan)#vlan 99
  • S1(config-vlan)#name management
  • S1(config-vlan)#end

Kiểm tra các VLANs đã tạo trên switch S1:

  • S1#show vlan brief

Cấu hình và đặt tên các VLANs trên switch S2, S3 như S1.

Cấu hình các port trên switch S2, S3:

  • S2:
    • S2(config)#interface range fa0/6, fa0/11, fa0/18
    • S2(config-if-range)#switchport mode access
    • S2(config-if-range)#no shutdown
  • S3:
    • S3(config)#interface range fa0/6, fa0/11, fa0/18
    • S3(config-if-range)#switchport mode access
    • S3(config-if-range)#no shutdown

Gán các port đến các VLANs trên switch S2, S3:

  • S2:
    • S2(config)#interface range fa0/6-11
    • S2(config-if-range)#switchport access vlan 30
    • S2(config-if-range)#interface range fa0/11-17
    • S2(config-if-range)#switchport access vlan 10
    • S2(config-if-range)#interface range fa0/18-24
    • S2(config-if-range)#switchport access vlan 20
    • S2(config-if-range)#end
    • S2#copy running-config startup-config

Cấu hình tương tự trên S3

Gán VLAN management trên switch S1, S2, S3:

  • S1:
    • S1(config)#interface vlan 99
    • S1(config-if)#ip address 172.17.99.11 255.255.255.0
    • S1(config-if)#no shutdown
  • S2:
    • S2(config)#interface vlan 99
    • S2(config-if)#ip address 172.17.99.12 255.255.255.0
    • S2(config-if)#no shutdown
  • S3:
    • S3(config)#interface vlan 99
    • S3(config-if)#ip address 172.17.99.13 255.255.255.0
    • S3(config-if)#no shutdown

Cấu hình trunking và native VLAN cho các port trunking trên các switch S1, S2, S3:

  • S1:
    • S1(config)#interface range fa0/1-5
    • S1(config-if-range)#switchport mode trunk
    • S1(config-if-range)#switchport trunk native vlan 99
    • S1(config-if-range)#no shutdown
    • S1(config-if-range)#end
  • S2:
    • S2(config)#interface range fa0/1-5
    • S2(config-if-range)#switchport mode trunk
    • S2(config-if-range)#switchport trunk native vlan 99
    • S2(config-if-range)#no shutdown
    • S2(config-if-range)#end
  • S3:
    • S3(config)#interface range fa0/1-5
    • S3(config-if-range)#switchport mode trunk
    • S3(config-if-range)#switchport trunk native vlan 99
    • S3(config-if-range)#no shutdown
    • S3(config-if-range)#end

Chúc các bạn thành công!

Để lại ý kiến của bạn:

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

0888.550.111